Ecu - Can-Am DS-450 Forum :: DS450HQ.com
Engine/EFI/Drivetrain Discuss engine, fuel injection, air intake, and drivetrain modifications to your Can-Am DS450 in here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-14-2018, 09:46 AM Thread Starter
Junior Member
 
Join Date: Jul 2014
Posts: 19
Ecu

All the sudden having problems with my 08 ds450 going into limp mode. I know that's an issue with the 08's, so does anyone know is any company or someone still can remove the limp mode? if not does anyone have a R111L ecu laying around? Thanks
nick_742 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-14-2018, 08:48 PM
Super Moderator
 
bad moose's Avatar
 
Join Date: Jun 2010
Location: Valley Center KS
Posts: 4,307
Liked: 28 times
Have you tried BCS yet?

08 ds 450
Motworks SR4 G2
BCS Intake w/ KN airfilter
Pink Wire Mod
BCS Basket
Epic a arms w/ kyb remote ressi shocks
XMX rear shock
XMX stem and bars

Sig worthy quotes:
I know I'm going to Hell.

Now it's just a matter of go big or go home.
bad moose is offline  
post #3 of 4 (permalink) Old 01-20-2018, 11:25 AM Thread Starter
Junior Member
 
Join Date: Jul 2014
Posts: 19
Yes I did, they told me that they cant remove the limp mode anymore and that I would have to buy the r111L from someone. But he did say that there might be a guy out there that can do it. But it just doesnt make any sense to me why all the sudden its going into limp mode and its stuck in it all the time. It never did this when I got done with building the motor and everything, and I rode it for 2 seasons and never had an issue until now.
nick_742 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 05-08-2018, 11:22 AM
Super Moderator
 
alex-ds's Avatar
 
Join Date: Mar 2010
Location: Barcelona, Spain
Posts: 576
Liked: 24 times
limp mode is present on all years on stock ECU.

Purge coolant, add reflective tape shield to the fuel tank and drill big holes on your fender plastics. Your fan is working? Unplug your CTS connector and will see.

I just have limp mode problems on a race cause of mud on August (very hot weather in Europe).

Youtube Channel Quad
http://www.youtube.com/user/alexraptor350
Index of Service Manuals
http://quads.ddns.net
alex-ds is offline  
Reply

  Lower Navigation
Go Back   Can-Am DS-450 Forum :: DS450HQ.com > Can-Am DS450 Tech Discussion > Engine/EFI/Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am DS-450 Forum :: DS450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome