Updated Clutch cover doesnt line up? PLEASE HELP!!! - Can-Am DS-450 Forum :: DS450HQ.com
Engine/EFI/Drivetrain Discuss engine, fuel injection, air intake, and drivetrain modifications to your Can-Am DS450 in here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-07-2019, 11:13 PM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 1
Updated Clutch cover doesnt line up? PLEASE HELP!!!

Hey guys. New here. Been lurking here for a long time. Read countless threads on the updated clutch cover/basket fixes. So I went ahead and got all the parts from my local can am dealer to the the fix on my 08 ds 450. So everything was going smoothly. Got everything installed and ready to put the updated cover back on and one of the bolt holes on the right side by the shifter doesn't line up? All the other holes line up but this one? Has anyone else had this problem? I've searched forever trying to find any info but no luck. If anyone has any info please let me know. Thanks alot
RDrida is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Can-Am DS-450 Forum :: DS450HQ.com > Can-Am DS450 Tech Discussion > Engine/EFI/Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am DS-450 Forum :: DS450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Similar Threads
Thread Thread Starter Forum Replies Last Post
New to the forum, Clutch questions ike450r Member Introductions 1 03-27-2016 02:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome