Ds has large hole in base - Can-Am DS-450 Forum :: DS450HQ.com
Engine/EFI/Drivetrain Discuss engine, fuel injection, air intake, and drivetrain modifications to your Can-Am DS450 in here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-12-2020, 01:49 PM Thread Starter
Junior Member
 
Join Date: Oct 2020
Posts: 2
Ds has large hole in base

I rode my ds this weekend and put a large hole in the front of the base. Taking it out now. The odd thing is that it was still running, so it does not seem like the rod. Anyone have this? Also, where is the best place to find parts, gasket sets, piston, cams.... is there a different piston in the X model? Thanks
Tashline is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-13-2020, 07:59 AM Thread Starter
Junior Member
 
Join Date: Oct 2020
Posts: 2
Update, the crank broke. Any ideas on where to buy a new one?
Tashline is offline  
Reply

  Lower Navigation
Go Back   Can-Am DS-450 Forum :: DS450HQ.com > Can-Am DS450 Tech Discussion > Engine/EFI/Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am DS-450 Forum :: DS450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome