Hello ds450 owners. I got a starting issue. - Can-Am DS-450 Forum :: DS450HQ.com
Member Introductions Just registered? Say hello to the DS450HQ community! Tell us about your ride and where you are located! Did you just pick up your Can-Am DS450 and your ready to show it off? We want to hear about it!

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-08-2018, 08:45 AM Thread Starter
Junior Member
 
Simon82's Avatar
 
Join Date: Apr 2018
Posts: 2
Hello ds450 owners. I got a starting issue.

My ds is having trouble cranking over to start. It cranks once and stops, again and again with no start and drains the new battery real quick
Just changed oil, spark plugs, filters, starter solenoid and new 10amp battery.
After a hard start got it going, rode it for about 20mins and accidentally stalled it and it wouldn't fire up again just getting about 1 rotation when I try to fire it up and stops, over and over.
Any suggestions?
Simon82 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-12-2018, 11:44 AM
Junior Member
 
Join Date: Apr 2018
Posts: 2
Possibly a decompression Cam Lever issue
Improvise247 is offline  
post #3 of 6 (permalink) Old 04-14-2018, 06:34 PM
Junior Member
 
Join Date: Apr 2018
Posts: 1
Hello guys iwant to ask what valve shims work in the ds 450?
Thanks for helping.
adam20019 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 04-15-2018, 07:14 PM
Super Moderator
 
bad moose's Avatar
 
Join Date: Jun 2010
Location: Valley Center KS
Posts: 4,307
Liked: 28 times
If I remember correctly the KTM one will work. It's been a few years though.

08 ds 450
Motworks SR4 G2
BCS Intake w/ KN airfilter
Pink Wire Mod
BCS Basket
Epic a arms w/ kyb remote ressi shocks
XMX rear shock
XMX stem and bars

Sig worthy quotes:
I know I'm going to Hell.

Now it's just a matter of go big or go home.
bad moose is offline  
post #5 of 6 (permalink) Old 05-01-2018, 05:17 PM Thread Starter
Junior Member
 
Simon82's Avatar
 
Join Date: Apr 2018
Posts: 2
Starting issue fixed! It was the exhaust cam decompressor
That tiny spring inside that's responsible for pushing the decompression mechanism out was weak and not functioning properly
Got it fixed now it starts up smooth again
Thanks me 😀
Simon82 is offline  
post #6 of 6 (permalink) Old 11-13-2020, 03:15 PM
Junior Member
 
Join Date: Nov 2020
Posts: 1
how did you fix it?
brian825 is offline  
Reply

  Lower Navigation
Go Back   Can-Am DS-450 Forum :: DS450HQ.com > Can-Am DS450 Headquarters > Member Introductions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am DS-450 Forum :: DS450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Best Aftermarket Exhaust for DS450 in year 2016? Z3r0Eff3ct Engine/EFI/Drivetrain 3 04-19-2016 11:57 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome