Can-Am DS-450 Forum :: DS450HQ.com - Reply to Topic
General Discussion This section contains all Can-am DS450 General Discussions.

Thread: Fuel pump starter issue Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Can-Am DS-450 Forum :: DS450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
09-25-2019 06:31 PM
Sizwe It's the main relay (middle one),had the same problem
07-23-2019 10:11 PM
Braaaap_115 Also. Before when it ran. I could turn it off and pull the key but it would still have power for 30 seconds then shut off. No longer does that
07-23-2019 09:52 PM
Braaaap_115
Fuel pump starter issue

I recently got a 08ds 450. Sat in a barn for 6 years. Tore it down cleaned it up and got it running. Ran amazing. Turned it off for 10 mins came back to get my first ride on it and nothing. I turn the key, the lights come on but the fuel pump never primes and the starter wonít turn over. However I can jump from the solenoid but the fuel pump wonít prime so it wonít start. I checked with a volt meter and the fuel pump isnít even getting any power. Someone please help

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome