Can-Am DS-450 Forum :: DS450HQ.com banner
1 - 19 of 19 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Had a LOT of issues with my new 09 DS 450 x mx...

It doesn't come with a tether btw, BRP changed their minds and haven't told anyone yet, the toe was "out" an inch from the factory and not even on either side so you couldn't even drive it a lap (poor quality control) I blew the front shock the first weekend out, and tried to adjust the rear shock to put the rings to the top and it blew also, then it sat in the dealer's for 3 weeks...

nothings has changed with the clutch.

i put a deposit in aug, got the bike about 5 weeks ago, rode it for one weekend and its been in the shop ever since. dealer dragged their feet a lot and the bike sat and sat. I paid a lot of money for it and the quality is not their. I'm really disappointed. I used to ride yammie, should've stuck with it.
 

·
Registered
Joined
·
58 Posts
Man. Im sorry that happened. My dealer, Chapparral treated me the same way when my clutch and tranny blew on my ltr. Never buying a quad from them again. Lost lots of $ off that.
 

·
Registered
Joined
·
10 Posts
should have got a LTR. haha that sucks tho, its my feeling if your paying that much money for something it better work and not crap out on ya a couple weeks or so down the road. m2c
 

·
Registered
Joined
·
58 Posts
<div class='quotetop'>QUOTE (1fastLTR @ Dec 10 2008, 04:11 PM) <{POST_SNAPBACK}></div>
should have got a LTR. haha that sucks tho, its my feeling if your paying that much money for something it better work and not crap out on ya a couple weeks or so down the road. m2c[/b]
+1 for ltr's reliability. for sure!
 

·
Registered
Joined
·
459 Posts
<div class='quotetop'>QUOTE (1fastLTR @ Dec 10 2008, 05:11 PM) <{POST_SNAPBACK}></div>
should have got a LTR. haha that sucks tho, its my feeling if your paying that much money for something it better work and not crap out on ya a couple weeks or so down the road. m2c[/b]

Come on ltrs have their problems too.
 

·
Registered
Joined
·
58 Posts
That they do. Tranny's go out alot. Especially 3rd gear. But Ive never had to adjust valve clearance or really do any engine work since I got mine. Ive put almost 300 hrs on it so far
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
<div class='quotetop'>QUOTE (Spontoon @ Dec 11 2008, 10:23 PM) <{POST_SNAPBACK}></div>
My XC has had no problems. Interesting. Have you reported the dealer to BRP?[/b]
Don't get me going...those issues aren't the worst one...there is something wrong with the front end...when you lift up on the bumper one tire comes off the ground by almost half an inch while the other stays on the ground. The dealer couldn't figure it out, swapped the a-arms with another model, and eliminated the swing arm...we tried other shocks as well...they put the tires on opposite sides to realize that the tires aren't exactly the same either, so that masked the problem. We brought it home and put tires off my husband's LTR on both front and back, only to see the problem come back. we reported it to BRP and were on the phone constantly, and they basically told us tough and suck it up. Now we are in a fight with BRP because they say its not a safety issue, and we have two other mechanics telling us it is. BRP has been nothing but rude to us. So basically, we paid all that money, rode the bike for one weekend, besides the other problems, realized its got a serious issue with the front end, the dealer won't do anymore because BRP told them to stop trying to diagnose the problem, so they've given up.

I"M NOT HAPPY WITH BRP AT ALL. We're now taking it higher in BRP but I doubt anything will come of it. I'LL NEVER BUY CAN-AM EVER AGAIN.
 

·
Registered
Joined
·
58 Posts
Damn. I heard that they used to have good customer service a couple years ago. I guess not. Im sorry. Makes me wonder about purchasing a can am.
 

·
Registered
Joined
·
459 Posts
My Can Am dealer is the best. I broke a ball joint 2 weekends ago and they are replacing them on both sides. They didn't try to claim it was to to racing or abuse and they're replacing my radiator hoses. I found out they was a service bulletin released a couple of days ago about rear engine mounts and fly wheel bolts and they are going to fix that also. I feel sorry for all you guys who's dealer is given them no respect.
 

·
Registered
Joined
·
58 Posts
Thats good to hear that it is mostly how the dealer is. I know that it is usually by chance and on who helps you.

Same thing with my ipod. I took it in to get it replaced and I was basically told that it was my fault. I went in 2 days later and got it replaced no-questions-asked.
 

·
Registered
Joined
·
84 Posts
Customer service is a thing of the past. Its crap. Sorry to hear about your problems. Its not only can ams having issues. Sounds like the quad is a problem quad like my 08 ltr has been. Some times you just get them. Nothings perfect.
 

·
Registered
Joined
·
323 Posts
my rear brakes quit working too. what's up w/ them? i never use them, but my buddy rode it and he noticed they weren't working.
 

·
Registered
Joined
·
224 Posts
mine worked great untill i bent the axle a lil bit then they wore really fast and whent out completly and alot of air was in the brake lines took forever to get it all out
 

·
Registered
Joined
·
4,819 Posts
thank god i found people having problems with can-am too!

first off, hey, harley here, new to the site, but not to the sport.

heres the story...
in November i was talked into buying a 08 ds450 efi, and picked it up just in time for thanksgiving. i rode it for a week straight, had no problems till my clutch started squealing. got home, looked online and saw others had this happen too. so no big deal. did my oil change, took it back out and it ran great. then my next ride, just a week later, my clutch completely GAVE OUT. as in i pulled in the lever, and it failed to disengage. so i thought the cord was caught somewhere. but it wasn't. got back to camp and took the clutch apart, but couldn't see a problem, so i reassembled it, and it worked fine. well it continued to do this for another two weeks, after about 2 hours of riding the clutch would get stuck engaged. shit, just before the Christmas and new years ride. well i left the quad at home, and just borrowed a bike. so when i finally get back into town i take the quad to my local shop, (January 13th), and they say i need a new clutch, but that BRP has a update clutch recall or something, and that they'll order parts right away. so here it is, February 17th and i still have no quad. over a month in the shop now, and they say they are waiting on a set of hexagonal bolts that were supposed to come with the clutch, but didn't, so had to be ordered separately. ive called BRP and they have been ridiculously unhelpful with finding out were the parts are and when they are supposed to arrive. so i got a hold of the shop, and they said there waiting for a certain bolt, and gave me the part number, but i looked at BRPs online catalog and its a bolt for the starter...wtf? anyone know whats going on here?


oh and i see someone else had problems with the front end also! my front right tire canters in by almost 5 degrees. went to have it replaced, 1400 bucks later the same problem is there. dealer said that its from jumping and the aluminum frame cant handle it! are you kidding me?!?!? i also ordered a pipe, filter, and programmer and there just sitting in my garage now. what a waste!

keep in mind the bike became unridable just one month after buying it! hasnt been ridden since early december!!!
 
1 - 19 of 19 Posts
Top