Can-Am DS-450 Forum :: DS450HQ.com banner
1 - 5 of 5 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
:1zhelp:So i went to run a few practice motos last sunday and forgot to turn my key off. When i unloaded monday the battery was dead which is no big deal. So i put it on the battery charger for an hour or two on 12v 2amp charge. When i went to start it the starter solinoid was junk. Still not that big of a deal i can still cross the posts to start it. But i have to have the chager on the thing to get it to start still, on 10 amp to. Once its started it seems to idle fine but when i give it gas it dies after reving. I checked all the fuses i could find, the ones in back and on the shifter side of the motor. It seems like it doesnt get enough fuel to me, yes theres gas in it. If its the ecu ill get a power commander to bypass it. Just wondering if anyone has had this problem or any idea as to what it could be. Trying not to take it to the dealer if at all possible. :suicide:
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #2 ·
So i pulled a fuel line to check pressure and everything seem to be ok. I think its a charging problem now because the idiot lights seem to flicker when its not on the battery charger. Maybe it recharges through the solenoid, which i know is messed up. Ill check it with the volt meter tomorrow to see if it has a least 12v going back to the battery. Ill let you guys know what i find out.
 

·
Registered
Joined
·
117 Posts
I'm not sure on the DS but on my cannondale if the battery wasn't holding over 12 volts at all times the FI system would shut down and foul the spark plug. Then you were done until you changed the plug and the old one would be junk. I would let it sit all night with the 2 amp charger on and the key off to make sure it gets a charge. That or maybe the battery is junk?
 

·
Registered
Joined
·
1,667 Posts
The battery could be junk. They don't last that long if they get drained. I would try and get a new solenoid too. There not to much, around 40 bucks. If your still having the problem I would bring it to the dealer, and put it on buds. It will throw a code, and you can figure it out from there.
 

·
Registered
Joined
·
224 Posts
this happnd to me but the battery cable was loose lol
 
1 - 5 of 5 Posts
Top