Can-Am DS-450 Forum :: DS450HQ.com banner
1 - 9 of 9 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
So I've just bought a 2010 DS xmx. There seems to be a real loud ticking/ maybe slapping noise coming from engine at idle?? Goes away when it is revved. Could it be cam chain? Is it common and fixable? I'm pretty concerned
 

·
Registered
Joined
·
438 Posts
the cam chain tensioner works off oil pressure. I'd check the oil screen at the bottom of the oil tank if that gets plugged up you'll lose oil pressure as well
 

·
Premium Member
Joined
·
4,307 Posts
Did you clean the strainer in the oil tank? Like alex said these engines are noisier than most. Did it just start doing it or has it always done this?
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #8 ·
Yeah checked the oil tank when I did oil change. I've only just aquired the bike so not sure how long it's been going for? I understand that engines are noisy but is a very distinguished sound. And when I switch engine off it makes one last louder tic when it stops
 

·
Registered
Joined
·
3 Posts
Yeah checked the oil tank when I did oil change. I've only just aquired the bike so not sure how long it's been going for? I understand that engines are noisy but is a very distinguished sound. And when I switch engine off it makes one last louder tic when it stops
Did you ever figure out what it was? Have the same issue on my 08 ds450. Ready to tear the motor apart but would rather not If I don’t need to.
 
1 - 9 of 9 Posts
Top