Can-Am DS-450 Forum :: DS450HQ.com banner
1 - 5 of 5 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
I finally got my racer support program parts. I started installing the motoworks slip on tonight but it got too dark to finish. Plus I haven't even had it a day and I already put a little ding in it :suicide: so I thought I should take a break for the night. Anyways, I was just wondering one thing.

The slip on never came with, nor does it mention anything at all in the instructions about using a new exhaust clamp or the stock to fasten the slip on to the stock header. I would think you would need one, but the stock clamp is bigger than the motoworks pipe, and it has a little tab in the inside of it.

I was just curious if the slip on truely is just a slip on? no clamp needed? I didn't think it would be but I have no idea so I thought I'd just ask since I've never installed one before.

Thanks,
 

·
Registered
Joined
·
25 Posts
how long did it take to receive the pipe and stuff after getting accepted???
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #3 ·
Around 3 weeks.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #4 ·
I figured it out. Just slides on, no clamp needed.
 

·
Registered
Joined
·
87 Posts
We just went through the same dilema installing our race kit. Fortunately, a man who was much smarter than me was standing nearby and figured out that it just slipped on nice an snug and stayed there without needing any type of clamp. We put 40 minutes on the bike this afternoon and didn't have any problems with it.
 
1 - 5 of 5 Posts
Top