Can-Am DS-450 Forum :: DS450HQ.com banner
1 - 12 of 12 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Sup guys just picked up a 2008 ds 450efi and it's pretty clean love it in all but I'm having these couple issues. I have searched on here and came up with 1 of my problems maybe limp mode ? How would i solve that?????

Problem 1: If I'm out trailing riding or whatever I turn a corner fast or whatever the case may be I sometimes stall out because I can't get to the clutch in time so it will cut off and I try to restart it and it just cranks but does not turn over it will crank until the battery gets weak and I have to put it on the charger really quick. I have to turn the bike all the way off along with the red button then wait until the fan and neutral light cuts off then turn the bike back on and it will start fine. Same thing happens no matter how long I ride 3 mins or 30mins.

Problem 2: I have to turn the key all the way back (the third turn) to start the bike if I turn the key to the second position the lights will cut on but the bike will not start if i try and start it, it only will start In the last position. The bike will not run with the lights on and if I turn the key to the lights the bike cuts off. The lights that come on are either very dim and can't see anything or not on at all so I had to cut my ride short because it got dark.

I have not had time to take it apart seeings how I just got it today , I took the seat off and air box has no lid I have not checked to see if the pink wire has been cut i believe everything is stock on the bike . But what should I look for in fixing my problems???? ANY HELP WOULD BE GREAT THANKS GUYS
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #2 ·
just took the front plastics off and theres 3 wires that connect to the ignition switch or the harness you have to take off to get the plastic off that are missing out the harness idk what this means?

1. one solid yellow wire
2. one solid black wire (with a white line)
3. one orange wire ( with a yellow line)

what does this mean? part of any of my problems
 

·
Registered
Joined
·
730 Posts
Take some pics and post them.
 

·
Registered
Joined
·
730 Posts
They should all be connected n
 

·
Premium Member
Joined
·
4,307 Posts
On problem 1 are you cycling the key and allowing the fuel pump to prime back up? It's EFI the fuel sys has to be "reset" for it to start easily. Sometimes I get lucky and can fire it back up If I'm quick but most times I end up cycling the key and let the fuel pump do its thing.

On problem 2 I think you have that one figured out.
 

·
Premium Member
Joined
·
4,307 Posts
Oh. And while you have the plastics off. Change your relays. Swiss cheese the plastics at the fuel tank, and heat tape the bottom of the tank also, if that hasn't been done yet. Snip the pink wire if that hasn't been done yet either. Then put it back together and enjoy.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #8 ·
Sweet thanks alot moose ill do all of that when I get home currently at work now, from what I've been seeing "You Da Man" around here moose lol but I figured out where the orange wire with the yellow line goes I spliced it with the cream wire now my lights work with the quad running but my fan does not work I think it's a relay, there's still TWO wires that hang free where do they go I know there suppose to be in the harness but in what color order like left to right which wire goes in what pin? CAN SOMEONE TAKE A PIC OF THERE HARNESS SO I CAN SEE WHAT WIRE GOES WHERE? Like a close up pic of the harness for the ignition so I can have a guide I don't have a service manual or anything

THANKS GUYS
 

·
Premium Member
Joined
·
4,307 Posts
Beige pin c comes from ecm fuse
orange yellow pin d multifunction stop switch
black white pin e ecm
black red pin a head light
black pin f ground
 

·
Premium Member
Joined
·
4,307 Posts
Oh I'm not the man on these. Just some flunky with a schematic and shop manual. LOL
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #11 ·
Thanks moose before I read your post I kinda figured it out , I spliced the other wires with 2 different ones can't remember until I take the plastics off again but everything works as it should now, the only wire that is still hanging taped off it the black white pin e ecm

What exactly does this black white pin e ecm do? What purpose does it serve being unhooked? My quad runs great so I can't tell a difference maybe idk any better
 

·
Premium Member
Joined
·
4,307 Posts
If it ain't broke then ...

I just remember it comming from the ecm fuse. I'm too lazy to go get the schematic right now.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top